Home » Server Options » Data Guard » Primay & Standby on Different DB versions & OS
Primay & Standby on Different DB versions & OS [message #153760] Wed, 04 January 2006 00:11 Go to next message
asangapradeep
Messages: 128
Registered: October 2005
Location: UK
Senior Member
hi,

i got a primary database on a machine where the OS is RHEL 3 and oracle database software is 10gR1.
i've created a standby on a machine where the OS is RHEL 4 and oracle database software is 10gR2.

i've used rman to create the standby and before creating the standby changed the compatible parameter to 10.1.0.2.0 (same as primary DB compatible parameter) in the standby pfile. i was able to mount and start the recovery process. i did a switch log on the primary and checked the status and error columns from v$archive_dest and it showed
status error and error given was ORA-16039: RFS request version mismatch.

then i shutdown the standby and change the compatible parameter to 10.2.0.1.0 which is the compatible version for 10gR2. but still the same error was given when i tried a log switch.

Is it possible to have such a data guard configuration with different OS and DB software versions?
if so how to resolve the above issue of version mismatch?

Thank you.
Re: Primay & Standby on Different DB versions & OS [message #153835 is a reply to message #153760] Wed, 04 January 2006 05:59 Go to previous message
waseem_aijaz
Messages: 16
Registered: December 2005
Location: Kingdom of Saudi Arabia
Junior Member
In oracle 9i release 2 documentation, I read the following...


"The same Oracle software release must be used on both the primary and standby databases. The operating system running on the primary and standby locations must be the same, but the operating system release does not need to be the same."


-Hope this helps you.
Previous Topic: Dataguard - How to Manually Apply Archive Logs
Next Topic: Physical Standby Implementation
Goto Forum:
  


Current Time: Thu Oct 22 18:25:50 CDT 2020